Nintendo Channel is inaccessible

Incident Report for WiiLink

Resolved

The outage has been resolved, however you need to repatch Nintendo Channel to restore service. You can follow https://wiilink.ca/guide/update for instructions on how to do this.
Posted Mar 19, 2025 - 14:43 EDT

Identified

We are aware that Nintendo Channel is currently unavailable, throwing error 262000 whenever you try to use the channel. Please be patient as we work to fix this!
Posted Mar 12, 2025 - 17:31 EDT
This incident affected: Nintendo Channel.