Check Mii Out Channel Contest outage

Incident Report for WiiLink

Resolved

Users who have Xfinity as an ISP are required to update their channel.
Posted Mar 26, 2025 - 14:16 EDT

Update

Contests now work, however users of Xfinity still do not work.
Posted Mar 23, 2025 - 17:04 EDT

Investigating

Current contests are not appearing. Furthermore, users who has Xfinity as an ISP are unable to submit Miis, register artisans, or use contests.
Posted Mar 23, 2025 - 16:54 EDT
This incident affected: Check Mii Out Channel / Mii Contest Channel.