Demae Dominos
Incident Report for WiiLink
Resolved
Not really sure how to properly deal with this so to be continued - possum
Posted Nov 08, 2022 - 19:43 EST
Update
If you are a tester you will be pinged in the discord when it is back up -Possum
Posted Oct 25, 2022 - 03:46 EDT
Identified
Currently down while we deal with SSL setup
Posted Oct 25, 2022 - 03:45 EDT
This incident affected: Demae Dominos.