Everybody Votes Channel outage

Incident Report for WiiLink

Resolved

This incident has been resolved.
Posted Apr 08, 2025 - 19:29 EDT

Investigating

We are currently investigating this issue.
Posted Apr 08, 2025 - 13:55 EDT
This incident affected: Everybody Votes Channel.